# S3 sink connector fails with "invalid version id specified" error

**URL:** <https://ask.lenses.io/t/s3-sink-connector-fails-with-invalid-version-id-specified-error/420>\
**Category:** Apache Kafka Connectors\
**Tags:** kafka-connect, s3\
**Created:** [August 22, 2025, 8:48am UTC](https://ask.lenses.io/t/s3-sink-connector-fails-with-invalid-version-id-specified-error/420 "2025-08-22T08:48:35Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![APA](https://avatars.discourse-cdn.com/v4/letter/a/da6949/32.png) [@APA](https://ask.lenses.io/u/APA)\
**Post date:** [August 22, 2025, 8:48am UTC](https://ask.lenses.io/t/s3-sink-connector-fails-with-invalid-version-id-specified-error/420/1 "2025-08-22T08:48:35Z")

</div>

I have a s3 sink connector (10.0.0) configured to basically make a golden copy of my messages on our pure storage system. It runs but after a while it fails with the error

`„invalid version id specified (Service: S3, Status Code: 400, Request ID: null).`

Is this implying that the bucket must have versioning activated?

In the connector documentation I didn‘t find any information that this might be a requirement or is the error related to something totally different ?
