# Unable to integrate my kafka connector to lenses.box connectors list

**URL:** https://ask.lenses.io/t/unable-to-integrate-my-kafka-connector-to-lenses-box-connectors-list/99
**Category:** Apache Kafka Connectors
**Tags:** kafka-connect
**Created:** [July 26, 2023, 10:03am UTC](https://ask.lenses.io/t/unable-to-integrate-my-kafka-connector-to-lenses-box-connectors-list/99 "2023-07-26T10:03:11Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![hachemsfar](https://dub1.discourse-cdn.com/flex017/user_avatar/ask.lenses.io/hachemsfar/32/61_2.png) [@hachemsfar](https://ask.lenses.io/u/hachemsfar)
#### Post date: [July 26, 2023, 10:03am UTC](https://ask.lenses.io/t/unable-to-integrate-my-kafka-connector-to-lenses-box-connectors-list/99/1 "2023-07-26T10:03:11Z")

</div>

Hello everyone,

i want to integrate my custom kafka connectors to lenses UI. but I got this error  
can you help me ?  
docker-compose.yml

```auto
version: '3'
services:   
  lenses:
    image: lensesio/box:latest
    container_name: lenses
    ports:
      - "3030:3030"
      - "9092:9092"
    environment:
      ADV_HOST : 127.0.0.1
      EULA: https://licenses.lenses.io/d/?id=KEY
      plugin.path: /connectors
      
  connect:
    image: confluentinc/cp-server-connect:7.4.0
    hostname: connect
    container_name: connect
    volumes: 
        - "./connectors:/usr/share/confluent-hub-components"
    depends_on:
      - lenses
    ports:
      - "8083:8083"
      - "7071:7071"
      - "1111:1111"
    environment:
      CONNECT_BOOTSTRAP_SERVERS: broker:9092
      CONNECT_REST_ADVERTISED_HOST_NAME: connect
      CONNECT_GROUP_ID: compose-connect-group
      CONNECT_CONFIG_STORAGE_TOPIC: docker-connect-configs
      CONNECT_CONFIG_STORAGE_REPLICATION_FACTOR: 1
      CONNECT_OFFSET_FLUSH_INTERVAL_MS: 10000
      CONNECT_OFFSET_STORAGE_TOPIC: docker-connect-offsets
      CONNECT_OFFSET_STORAGE_REPLICATION_FACTOR: 1
      CONNECT_STATUS_STORAGE_TOPIC: docker-connect-status
      CONNECT_STATUS_STORAGE_REPLICATION_FACTOR: 1
      CONNECT_KEY_CONVERTER: org.apache.kafka.connect.storage.StringConverter
      CONNECT_VALUE_CONVERTER: io.confluent.connect.avro.AvroConverter
      CONNECT_VALUE_CONVERTER_SCHEMA_REGISTRY_URL: http://127.0.0.1:8081
      # CLASSPATH required due to CC-2422
      CLASSPATH: /usr/share/java/monitoring-interceptors/monitoring-interceptors-7.4.0.jar
      CONNECT_PRODUCER_INTERCEPTOR_CLASSES: "io.confluent.monitoring.clients.interceptor.MonitoringProducerInterceptor"
      CONNECT_CONSUMER_INTERCEPTOR_CLASSES: "io.confluent.monitoring.clients.interceptor.MonitoringConsumerInterceptor"
      CONNECT_PLUGIN_PATH: "/usr/share/java,/usr/share/confluent-hub-components"
      CONNECT_LOG4J_LOGGERS: org.apache.zookeeper=ERROR,org.I0Itec.zkclient=ERROR,org.reflections=ERROR,com.sap.conn.jco=ERROR,org.init.ohja.kafka.connect=DEBUG
      _JAVA_OPTIONS: -Xmx6g -Xms6g -XX:MaxPermSize=1024m
      CONNECT_EXACTLY_ONCE_SOURCE_SUPPORT: enabled

```

```auto
===> User
uid=1000 (appuser) gid=1000 (appuser) groups=1000 (appuser)
===> Configuring ...

Running preflight checks ...
===> Check if Kafka is healthy .
Picked up _JAVA OPTIONS: -Xmx6g -Xms6g -XX:MaxPernSize=1024m
OpenJDK 64-Bit Server WM warning: Ignoring option MaxPermSize; support was removed in 8.0
Error while running kafka-ready.
org.apache.kafka.common.KafkaException: Failed to create new KafkaAdminClient
at org.apache.kafka.clients.adnin.KafkaAdminClient.createlnternal (KafkeAdminClient. Java:551)
at org.apache.kafka.clients.adnin.Admin.create (Admin. Java: 144)
at org.apache.kafka.clients.adnin.AdninClient.create (minClient.java:49)
at io.confluent.adnin.urils.ClusterStatus.isKafkaReady (CLusterStatus. java: 136)
at io.confluent.admin.utils.cli.KafkaReadyConmand. main (KafkaReadyCommand. java: 149)
Caused by: org.apache.kafka.common.config.ConfigException: No resolvable bootstrap urls given in bootstrap.servers
at org.apache.kafka.clients.ClientUrils.parseAndvalidateAddresses (CLientUrils. java: 39)
at org.apache.kafka.clients.ClientUrils.parseAndvalidateAddresses (CLientUtils. Java: 43)
at org.apache.kafka.clients.adnin.KafkaAdninClient.createlnternal (KafkaAdminClient. Java: 508)
4 more
Using log4j config /etc/cp-base-new/log4j.properties

```

---

<div class="post-metadata">

### Author: ![Marios](https://dub1.discourse-cdn.com/flex017/user_avatar/ask.lenses.io/marios/32/8_2.png) [@Marios](https://ask.lenses.io/u/Marios)
#### Post date: [July 28, 2023, 5:34pm UTC](https://ask.lenses.io/t/unable-to-integrate-my-kafka-connector-to-lenses-box-connectors-list/99/2 "2023-07-28T17:34:04Z")

</div>

Hello hachemsfar,

Lenses Box includes both Kafka, Kafka Connect, and Schema Registry, so you don’t have to setup a separate container for Kafka Connect.

Try to mount your connector plugins under `/connectors` inside Lenses Box, then once everything’s up, you can create new connectors via Lenses.

E.g:

```auto
version: '3'
services:   
  lenses:
    image: lensesio/box:latest
    container_name: lenses
    ports:
      - "3030:3030"
      - "9092:9092"
    environment:
      ADV_HOST : 127.0.0.1
      EULA: https://licenses.lenses.io/d/?id=KEY
    volumes: 
        - "./connectors

```

That’s all!
