Cannot see new Kafka Connect cluster in Lenses

I have two Kafka Connects configured. I can see them in the Admin screen, but I can only see one of them in the workspace. How can I resolve this?

Having permissions to manage connections does not automatically imply “Application Access” to these connections. Therefore, it is likely that your User Group does not have the permission enabled for this second connection cluster. You can edit this by going to the group, under “Application Permissions,” and then in “Connect Clusters Access,” grant permission to the new cluster. Take a look at the screenshots of the user’s screen, the admin’s screen, and then how it looks after the modification.

The user screen.

The Admin user with all permissions.

Changing the permissions for the user.

Normal user after the changed permissions.